华师一附中OI组
标题:
P2388 阶乘之乘
[打印本页]
作者:
vc_vitamine
时间:
2018-8-17 22:36
标题:
P2388 阶乘之乘
https://www.luogu.org/problemnew/show/P2388
题目背景
不告诉你……
题目描述
求出1!*2!*3!*4!*……*n!的末尾有几个零
输入输出格式
输入格式:
n(n<=10^8)
输出格式:
有几个零
输入输出样例
输入样例1:
10
输出样例1:
7
作者:
黄煦喆
时间:
2018-8-18 17:20
#include<iostream>
using namespace std;
long long n,x,s,ans;
int main()
{
cin>>n;
for(int i=5; i<=n; i+=5)
{
ans+=(x<<2);
s=i;
while(!(s%5))x++,s/=5;
ans+=x;
}
ans+=(n%5)*x;
cout<<ans;
return 0;
}
复制代码
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2