华师一附中OI组
标题:
P1567 统计天数
[打印本页]
作者:
admin
时间:
2018-7-3 16:47
标题:
P1567 统计天数
https://www.luogu.org/problemnew/show/P1567
题目描述
炎热的夏日,KC非常的不爽。他宁可忍受北极的寒冷,也不愿忍受厦门的夏天。最近,他开始研究天气的变化。他希望用研究的结果预测未来的天气。
经历千辛万苦,他收集了连续N(1<=N<=10^7)天的最高气温数据。
现在,他想知道最高气温一直上升的最长连续天数。
输入输出格式
输入格式:
*1行:一个整数N。1<=N<=10^7
*2行:N个空格隔开的整数,表示连续N天的最高气温。0<=最高气温<=10^9。
输出格式:
*1行:一个整数,表示最高气温一直上升的最长连续天数。
输入输出样例
输入样例#1:
10
1 2 3 2 4 5 6 8 5 9
输出样例#1:
5
说明
时间限制1s 内存限制128MB
作者:
YTC
时间:
2018-7-3 17:59
#include<iostream>
#include<cmath>
using namespace std;
int n,p,m,s,sum;
int a[10000001];
int main()
{
cin>>n;
for(int i=0;i<n;i++) cin>>a[i];
s=1;
for(int i=1;i<n;i++)
{
if(a[i]>a[i-1]) s++;
if(a[i]<=a[i-1]) s=1;
if(s>sum) sum=s;
}
cout<<sum;
return 0;
}
作者:
倚窗倾听风吹雨
时间:
2018-7-3 19:40
本帖最后由 倚窗倾听风吹雨 于 2018-7-4 19:24 编辑
#include<iostream>
using namespace std;
int n,t,i,j,maxt=0;
int a[10000010];
int main()
{
cin>>n;
for(i=1;i<=n;i++)cin>>a[i];
for(j=1;j<=n;j++)
{
if(a[j+1]>a[j])t++;
if(t>=maxt)maxt=t;
if(a[j+1]<=a[j])t=1;
}
cout<<maxt;
}
复制代码
作者:
admin
时间:
2018-7-3 20:16
你们两的程序越界了。数组
作者:
黄煦喆
时间:
2018-8-26 18:44
#include<iostream>
using namespace std;
int n,x,y,s,ans;
int main()
{
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>x;
ans=max(ans,s);
if(x>y)s++;
else s=1;
y=x;
}
cout<<ans;
return 0;
}
复制代码
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2