华师一附中OI组
标题:
P1126 机器人搬重物
[打印本页]
作者:
admin
时间:
2018-5-13 20:00
标题:
P1126 机器人搬重物
https://www.luogu.org/problemnew/show/P1126
题目描述
机器人移动学会(RMI)现在正尝试用机器人搬运物品。机器人的形状是一个直径1.6米的球。在试验阶段,机器人被用于在一个储藏室中搬运货物。储藏室是一个N*M的网格,有些格子为不可移动的障碍。机器人的中心总是在格点上,当然,机器人必须在最短的时间内把物品搬运到指定的地方。机器人接受的指令有:向前移动1步(Creep);向前移动2步(Walk);向前移动3步(Run);向左转(Left);向右转(Right)。每个指令所需要的时间为1秒。请你计算一下机器人完成任务所需的最少时间。
输入输出格式
输入格式:
输入的第一行为两个正整数N,M(N,M<=50),下面N行是储藏室的构造,0表示无障碍,1表示有障碍,数字之间用一个空格隔开。接着一行有四个整数和一个大写字母,分别为起始点和目标点左上角网格的行与列,起始时的面对方向(东E,南S,西W,北N),数与数,数与字母之间均用一个空格隔开。终点的面向方向是任意的。
输出格式:
一个整数,表示机器人完成任务所需的最少时间。如果无法到达,输出-1。
输入输出样例
输入样例#1:
9 10
0 0 0 0 0 0 1 0 0 0
0 0 0 0 0 0 0 0 1 0
0 0 0 1 0 0 0 0 0 0
0 0 1 0 0 0 0 0 0 0
0 0 0 0 0 0 1 0 0 0
0 0 0 0 0 1 0 0 0 0
0 0 0 1 1 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0
1 0 0 0 0 0 0 0 1 0
7 2 2 7 S
输出样例#1:
12
作者:
倚窗倾听风吹雨
时间:
2018-9-12 20:42
#include<iostream>
#include<queue>
#include<cmath>
using namespace std;
const int M=55;
struct node
{
int t,r,c,time;
}p;
char ch;
bool o[M][M],flag;
queue<node>q;
int n,m,gr,gc,vis[M][M],ans[5001],tot;
int main()
{
cin>>n>>m;
for(int i=1; i<=n; i++)
for(int j=1; j<=m; j++)
{
cin>>flag;
if(flag)
{
o[i][j]=1;
o[i-1][j-1]=1;
o[i-1][j]=1;
o[i][j-1]=1;
}
vis[i][j]=99999;
}
for(int i=1;i<=n;i++)
{
o[n][i]=1;
o[i][m]=1;
}
flag=0;
cin>>p.r>>p.c;
p.time=0;
cin>>gr>>gc;
cin>>ch;
if(ch=='N')
p.t=1;
if(ch=='E')
p.t=2;
if(ch=='S')
p.t=3;
if(ch=='W')
p.t=4;
q.push(p);
while(!q.empty())
{
if(q.front().r==gr && q.front().c==gc)
ans[++tot]=q.front().time;
for(int i=1; i<=4; i++)
{
p.t=q.front().t;
p.c=q.front().c;
p.r=q.front().r;
p.time=q.front().time+1;
if(i!=p.t)
{
p.time++;
if(abs(p.t-i)==2)p.time++;
}
p.t=i;
for(int j=1;j<=3;j++)
{
if(i==1)p.r--;
if(i==2)p.c++;
if(i==3)p.r++;
if(i==4)p.c--;
if(o[p.r][p.c] || p.r<=0 || p.c<=0 || p.r>n || p.c>m)break;
if(vis[p.r][p.c]>p.time)
{
q.push(p);
vis[p.r][p.c]=p.time;
}
}
}
q.pop();
}
if(tot==0)cout<<"-1"<<endl;
else
{
for(int i=1;i<=tot;i++)ans[1]=min(ans[1],ans[i]);
cout<<ans[1]<<endl;
}
return 0;
}
复制代码
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2