华师一附中OI组
标题:
P1478 陶陶摘苹果(升级版)
[打印本页]
作者:
admin
时间:
2018-5-13 13:50
标题:
P1478 陶陶摘苹果(升级版)
https://www.luogu.org/problemnew/show/P1478
题目描述
又是一年秋季时,陶陶家的苹果树结了n个果子。陶陶又跑去摘苹果,这次她有一个a公分的椅子。当他手够不着时,他会站到椅子上再试试。
这次与NOIp2005普及组第一题不同的是:陶陶之前搬凳子,力气只剩下s了。当然,每次摘苹果时都要用一定的力气。陶陶想知道在s<0之前最多能摘到多少个苹果。
现在已知n个苹果到达地上的高度xi,椅子的高度a,陶陶手伸直的最大长度b,陶陶所剩的力气s,陶陶摘一个苹果需要的力气yi,求陶陶最多能摘到多少个苹果。
输入输出格式
输入格式:
第1行:两个数 苹果数n,力气s。
第2行:两个数 椅子的高度a,陶陶手伸直的最大长度b。
第3行~第3+n-1行:每行两个数 苹果高度xi,摘这个苹果需要的力气yi。
输出格式:
只有一个整数,表示陶陶最多能摘到的苹果数。
输入输出样例
输入样例#1:
8 15
20 130
120 3
150 2
110 7
180 1
50 8
200 0
140 3
120 2
输出样例#1:
4
说明
所有数据:n<=5000 a<=50 b<=200 s<=1000
xi<=280 yi<=100
作者:
倚窗倾听风吹雨
时间:
2018-7-7 09:03
#include<iostream>
#include<algorithm>
using namespace std;
int i,s,n,a,b,ans;
struct apple
{
int h,f;
}k[6000];
bool cmp(apple x,apple y)
{
return x.f<y.f;
}
int main()
{
cin>>n>>s;
cin>>a>>b;
a=a+b;
for(i=1;i<=n;i++)
cin>>k[i].h>>k[i].f;
sort(k+1,k+n+1,cmp);
for(i=1;i<=n;i++)
if(a>=k[i].h)
{
s-=k[i].f;
if(s<0)break;
ans++;
}
cout<<ans;
}
复制代码
作者:
universehyf
时间:
2018-7-8 15:25
#include<iostream>
#include<algorithm>
using namespace std;
int n,s,a,b,c=0;
int i;
struct apple{
int x;int y;
}cc[6000];
bool px(apple c1,apple c2){return c1.y<c2.y;}
int main()
{
cin>>n>>s>>a>>b;
for(i=0;i<=n;i++) cin>>cc[i].x>>cc[i].y;
sort(cc,cc+n,px);
i=0;
while(s>=0)
{
if(a+b>=cc[i].x)
{
s=s-cc[i].y;
c++;
}
i++;
if(i>=n) break;
}
cout<<c-1;
return 0;
}
复制代码
作者:
吴语林
时间:
2018-7-29 20:27
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstring>
#include <map>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <cstdio>
#include <cstdlib>
using namespace std;
int n,w,t1,t,all=0;
struct node
{
int h,q;
}a[6000];
bool cmp(node x,node y)
{
return x.q<y.q;
}
int main()
{
scanf("%d%d",&n,&w);
scanf("%d%d",&t1,&t);t+=t1;
for(int i=1;i<=n;i++)
scanf("%d%d",&a[i].h,&a[i].q);
sort(a+1,a+1+n,cmp);
for(int i=1;i<=n;i++)
{
if(t>=a[i].h)
{
if(w-a[i].q>=0)
w-=a[i].q,all++;
else
{
printf("%d",all);
return 0;
}
}
}
printf("%d",all);
return 0;
}
复制代码
作者:
黄煦喆
时间:
2018-8-27 15:02
#include<iostream>
#include<algorithm>
using namespace std;
int a,b,s,n,t=1,tot,ans;
struct apple
{
int h,w;
}ap[5001];
bool operator< (apple a,apple b)
{
return a.w<b.w;
}
int main()
{
cin>>n>>s;
cin>>a>>b;
tot=a+b;
for(int i=1;i<=n;i++)cin>>ap[i].h>>ap[i].w;
sort(ap+1,ap+n+1);
while(t<=n)
{
if(ap[t].w<=s)
if(ap[t].h<=tot)ans++,s-=ap[t].w;
t++;
}
cout<<ans;
return 0;
}
复制代码
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2