华师一附中OI组
标题:
P3373 【模板】线段树 2
[打印本页]
作者:
admin
时间:
2018-5-13 01:11
标题:
P3373 【模板】线段树 2
https://www.luogu.org/problemnew/show/P3373
题目描述
如题,已知一个数列,你需要进行下面三种操作:
1.将某区间每一个数乘上x
2.将某区间每一个数加上x
3.求出某区间每一个数的和
输入输出格式
输入格式:
第一行包含三个整数N、M、P,分别表示该数列数字的个数、操作的总个数和模数。
第二行包含N个用空格分隔的整数,其中第i个数字表示数列第i项的初始值。
接下来M行每行包含3或4个整数,表示一个操作,具体如下:
操作1: 格式:1 x y k 含义:将区间[x,y]内每个数乘上k
操作2: 格式:2 x y k 含义:将区间[x,y]内每个数加上k
操作3: 格式:3 x y 含义:输出区间[x,y]内每个数的和对P取模所得的结果
输出格式:
输出包含若干行整数,即为所有操作3的结果。
输入输出样例
输入样例#1:
5 5 38
1 5 4 2 3
2 1 4 1
3 2 5
1 2 4 2
2 3 5 5
3 1 4
输出样例#1:
17
2
说明
时空限制:1000ms,128M
数据规模:
对于30%的数据:N<=8,M<=10
对于70%的数据:N<=1000,M<=10000
对于100%的数据:N<=100000,M<=100000
(数据已经过加强^_^)
样例说明:
作者:
吴语林
时间:
2018-7-29 19:35
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstring>
#include <map>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <cstdio>
#include <cstdlib>
using namespace std;
const int N = 2e5 + 10;
typedef long long LL;
LL sum[N * 4]= {0}, tag_add[N * 4]= {0}, tag_mul[N * 4]= {0},a[N],mo;
void build(int l, int r, int o)
{
if(l == r)
{
sum[o] = a[l];
tag_add[o] = 0,tag_mul[o]=1;
return ;
}
int mid = (l + r) >> 1;
build(l, mid, o * 2);
build(mid + 1, r, o << 1 | 1);
sum[o] = (sum[o << 1] + sum[o << 1 | 1])%mo;
tag_add[o] = 0,tag_mul[o]=1;
return ;
}
void update_mul(int L, int R, LL mul, int l, int r, int o)
{
if(L <= l && r <= R)
{
(sum[o] *= mul)%=mo;
(tag_mul[o] *= mul)%=mo;
(tag_add[o] *= mul)%=mo;
return ;
}
int mid = (l + r) >> 1;
if(tag_mul[o]!=1)
{
(sum[o << 1] *= tag_mul[o])%=mo;
(tag_mul[o << 1] *= tag_mul[o])%=mo;
(tag_add[o << 1] *= tag_mul[o])%=mo;
(sum[o << 1|1] *= tag_mul[o])%=mo;
(tag_mul[o << 1|1] *= tag_mul[o])%=mo;
(tag_add[o << 1|1] *= tag_mul[o])%=mo;
tag_mul[o] = 1;
}
if(tag_add[o])
{
(sum[o << 1] += tag_add[o] * (mid - l + 1))%=mo;
(tag_add[o << 1] += tag_add[o])%=mo;
(sum[o << 1|1] += tag_add[o] * (r - mid))%=mo;
(tag_add[o << 1|1] += tag_add[o])%=mo;
tag_add[o] = 0;
}
if(L <= mid) update_mul(L, R, mul, l, mid, o << 1);
if(R > mid) update_mul(L, R, mul, mid + 1, r, o << 1 | 1);
sum[o] = (sum[o << 1] + sum[o << 1 | 1])%mo;
}
void update_add(int L, int R, LL add, int l, int r, int o)
{
if(L <= l && r <= R)
{
(sum[o] += add * (r - l + 1))%=mo;
(tag_add[o] += add)%=mo;
return ;
}
int mid = (l + r) >> 1;
if(tag_mul[o]!=1)
{
(sum[o << 1] *= tag_mul[o])%=mo;
(tag_mul[o << 1] *= tag_mul[o])%=mo;
(tag_add[o << 1] *= tag_mul[o])%=mo;
(sum[o << 1|1] *= tag_mul[o])%=mo;
(tag_mul[o << 1|1] *= tag_mul[o])%=mo;
(tag_add[o << 1|1] *= tag_mul[o])%=mo;
tag_mul[o] = 1;
}
if(tag_add[o])
{
(sum[o << 1] += tag_add[o] * (mid - l + 1))%=mo;
(tag_add[o << 1] += tag_add[o])%=mo;
(sum[o << 1|1] += tag_add[o] * (r - mid))%=mo;
(tag_add[o << 1|1] += tag_add[o])%=mo;
tag_add[o] = 0;
}
if(L <= mid) update_add(L, R, add, l, mid, o << 1);
if(R > mid) update_add(L, R, add, mid + 1, r, o << 1 | 1);
sum[o] = (sum[o << 1] + sum[o << 1 | 1])%mo;
}
LL query(int L, int R, int l, int r, int o)
{
if(L <= l && r <= R)
{
return sum[o];
}
int mid = (l + r) >> 1;
if(tag_mul[o]!=1)
{
(sum[o << 1] *= tag_mul[o])%=mo;
(tag_mul[o << 1] *= tag_mul[o])%=mo;
(tag_add[o << 1] *= tag_mul[o])%=mo;
(sum[o << 1|1] *= tag_mul[o])%=mo;
(tag_mul[o << 1|1] *= tag_mul[o])%=mo;
(tag_add[o << 1|1] *= tag_mul[o])%=mo;
tag_mul[o] = 1;
}
if(tag_add[o])
{
(sum[o << 1] += tag_add[o] * (mid - l + 1))%=mo;
(tag_add[o << 1] += tag_add[o])%=mo;
(sum[o << 1|1] += tag_add[o] * (r - mid))%=mo;
(tag_add[o << 1|1] += tag_add[o])%=mo;
tag_add[o] = 0;
}
LL ans = 0;
if(L <= mid) ans += query(L, R, l, mid, o << 1);
if(R > mid) ans += query(L, R, mid + 1, r, o << 1 | 1);
return ans%mo;
}
int main()
{
int n, m;
scanf("%d %d %lld", &n, &m,&mo);
for(int i=1; i<=n; i++)
scanf("%lld", &a[i]);
build(1, n, 1);
while(m --)
{
int op;
scanf("%d", &op);
if(op == 1)
{
int l, r;
LL x;
scanf("%d %d %lld", &l, &r, &x);
update_mul(l, r, x, 1, n, 1);
}
else if(op == 2)
{
int l, r;
LL x;
scanf("%d %d %lld", &l, &r, &x);
update_add(l, r, x, 1, n, 1);
}
else
{
int l, r;
scanf("%d %d", &l, &r);
printf("%lld\n", query(l, r, 1, n, 1));
}
}
}
复制代码
作者:
zhwang
时间:
2018-7-30 10:33
#include<cstdio>
int n,m,mod;
int a[100000+100];
struct node
{
int l;int r;int sum;int tagsum;int tagmul;
}tree[400000+100];
int k,start,end;
void pushdown(int root)
{
tree[root*2].tagsum=(tree[root].tagsum+tree[root*2].tagsum*tree[root].tagmul)%mod;
tree[root*2+1].tagsum=(tree[root].tagsum+tree[root*2+1].tagsum*tree[root].tagmul)%mod;
tree[root*2].tagmul=(tree[root*2].tagmul*tree[root].tagmul)%mod;
tree[root*2+1].tagmul=(tree[root*2+1].tagmul*tree[root].tagmul)%mod;
tree[root*2].sum=(tree[root*2].sum*tree[root].tagmul+tree[root].tagsum*(tree[root*2].r-tree[root*2].l+1))%mod;
tree[root*2+1].sum=(tree[root*2+1].sum*tree[root].tagmul+tree[root].tagsum*(tree[root*2+1].r-tree[root*2+1].l+1))%mod;
tree[root].tagsum=0;
tree[root].tagmul=1;
}
void setup(int root,int s,int e)
{
tree[root].l=s;
tree[root].r=e;
tree[root].tagsum=0;
tree[root].tagmul=1;
if(s==e)
{
tree[root].sum=a[s];
}
else
{
setup(root*2,s,(s+e)/2);
setup(root*2+1,(s+e)/2+1,e);
tree[root].sum=tree[root*2].sum+tree[root*2+1].sum;
}
}
void update(int root,int s,int e,int flag,int num)
{
pushdown(root);
if(flag==1&&tree[root].l>=s&&tree[root].r<=e)
{
tree[root].tagmul=(tree[root].tagmul*num)%mod;
tree[root].tagsum=(tree[root].tagsum*num)%mod;
tree[root].sum=(tree[root].tagmul*tree[root].sum)%mod;
return;
}
if(flag==2&&tree[root].l>=s&&tree[root].r<=e)
{
tree[root].tagsum=(tree[root].tagsum+num)%mod;
tree[root].sum=(tree[root].sum+tree[root].tagsum*(tree[root].r-tree[root].l+1))%mod;
return;
}
int mid=(tree[root].l+tree[root].r)/2;
if(s<=mid)
{
update(root*2,s,e,flag,num);
}
if(e>=mid+1)
{
update(root*2+1,s,e,flag,num);
}
tree[root].sum=tree[root*2].sum+tree[root*2+1].sum;
}
int findout(int root,int s,int e)
{
pushdown(root);
if(tree[root].l>=s&&tree[root].r<=e)
{
return tree[root].sum%mod;
}
int mid=(tree[root].l+tree[root].r)/2;
return ((s<=mid?findout(root*2,s,e):0)+(e>mid?findout(root*2+1,s,e):0))%mod;
}
int main()
{
scanf("%d%d%d",&n,&m,&mod);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
setup(1,1,n);
for(int i=1;i<=m;i++)
{
scanf("%d",&k);
if(k==1||k==2)
{
int x;
scanf("%d%d%d",&start,&end,&x);
update(1,start,end,k,x);
}
else
{
if(k==3)
{
scanf("%d%d",&start,&end);
printf("%d\n",findout(1,start,end));
}
}
}
return 0;
}
复制代码
好像很TM腐朽啊,线段树是体力活
作者:
ZMQ
时间:
2018-8-16 21:57
提示:
作者被禁止或删除 内容自动屏蔽
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2