华师一附中OI组
标题:
P1141 01迷宫
[打印本页]
作者:
admin
时间:
2018-5-11 11:44
标题:
P1141 01迷宫
https://www.luogu.org/problemnew/show/P1141
题目描述
有一个仅由数字0与1组成的n×n格迷宫。若你位于一格0上,那么你可以移动到相邻4格中的某一格1上,同样若你位于一格1上,那么你可以移动到相邻4格中的某一格0上。
你的任务是:对于给定的迷宫,询问从某一格开始能移动到多少个格子(包含自身)。
输入输出格式
输入格式:
输入的第1行为两个正整数n,m。
下面n行,每行n个字符,字符只可能是0或者1,字符之间没有空格。
接下来m行,每行2个用空格分隔的正整数i,j,对应了迷宫中第i行第j列的一个格子,询问从这一格开始能移动到多少格。
输出格式:
输出包括m行,对于每个询问输出相应答案。
输入输出样例
输入样例#1:
2 2
01
10
1 1
2 2
输出样例#1:
4
4
说明
所有格子互相可达。
对于20%的数据,n≤10;
对于40%的数据,n≤50;
对于50%的数据,m≤5;
对于60%的数据,n≤100,m≤100;
对于100%的数据,n≤1000,m≤100000。
作者:
倚窗倾听风吹雨
时间:
2018-8-20 10:27
#include<iostream>
using namespace std;
int n,m,dr[4]= {0,-1,0,+1},dc[4]= {-1,0,+1,0},d,flag[1010][1010],a[10000001];
string s;
struct node
{
int r,c;
bool k;
} b[1000000];
bool mg[1010][1010];
int main()
{
cin>>n>>m;
for(int i=1; i<=n; i++)
{
cin>>s;
for(int j=0; j<s.size(); j++)
mg[i][j+1]=s[j]-'0';
}
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
int head=0,tail=1;
b[head].r=i;b[head].c=j;
if(flag[b[head].r][b[head].c]==0)
{
d++;
b[head].k=mg[b[head].r][b[head].c];
flag[b[head].r][b[head].c]=d;
while(head<tail)
{
for(int i=0; i<=3; i++)
{
if(b[head].r+dr[i]<=0 || b[head].r+dr[i]>n || b[head].c+dc[i]<=0 || b[head].c+dc[i]>n)
continue;
if(mg[b[head].r+dr[i]][b[head].c+dc[i]]!=b[head].k && flag[b[head].r+dr[i]][b[head].c+dc[i]]==0)
{
b[tail].r=b[head].r+dr[i];
b[tail].c=b[head].c+dc[i];
b[tail].k=mg[b[head].r+dr[i]][b[head].c+dc[i]];
flag[b[head].r+dr[i]][b[head].c+dc[i]]=d;
tail++;
}
}
head++;
}
a[d]=tail;
}
}
while(m--)
{
cin>>n>>d;
cout<<a[flag[n][d]]<<endl;
}
return 0;
}
复制代码
作者:
黄煦喆
时间:
2018-10-3 13:44
三个点RE
#include<iostream>
#include<deque>
#include<map>
using namespace std;
int n,m,a0,b0,ans,tmp;
bool b[1001][1001];
int bb[1001][1001];
int dx[4]= {0,0,1,-1};
int dy[4]= {-1,1,0,0};
struct xy
{
int x,y;
xy(int xx,int yy):x(xx),y(yy) {}
};
deque<xy>q;
map<int,int>mp;
int main()
{
cin>>n>>m;
string s;
for(int i=1; i<=n; i++)
{
cin>>s;
for(int j=1; j<=n; j++)b[i][j]=s[j-1]-'0';
}
while(m--)
{
q.clear();
cin>>a0>>b0;
if(bb[a0][b0])
{
cout<<mp[bb[a0][b0]]<<endl;
continue;
}
ans=0;
bb[a0][b0]=++tmp;
q.push_back(xy(a0,b0));
while(!q.empty())
{
xy t=q.front();
ans++;
q.pop_front();
for(int i=0; i<4; i++)
{
int tx=t.x+dx[i];
int ty=t.y+dy[i];
if(b[tx][ty]!=b[t.x][t.y]&&!bb[tx][ty]&&tx>=1&&tx<=n&&ty>=1&&ty<=n)
{
q.push_back(xy(tx,ty));
bb[tx][ty]=tmp;
}
}
}
mp[tmp]=ans;
cout<<ans<<endl;
}
return 0;
}
复制代码
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2