华师一附中OI组
标题:
P1085 不高兴的津津
[打印本页]
作者:
admin
时间:
2018-4-19 14:14
标题:
P1085 不高兴的津津
题目描述
津津上初中了。妈妈认为津津应该更加用功学习,所以津津除了上学之外,还要参加妈妈为她报名的各科复习班。另外每周妈妈还会送她去学习朗诵、舞蹈和钢琴。但是津津如果一天上课超过八个小时就会不高兴,而且上得越久就会越不高兴。假设津津不会因为其它事不高兴,并且她的不高兴不会持续到第二天。请你帮忙检查一下津津下周的日程安排,看看下周她会不会不高兴;如果会的话,哪天最不高兴。
输入输出格式
输入格式:
输入包括七行数据,分别表示周一到周日的日程安排。每行包括两个小于10的非负整数,用空格隔开,分别表示津津在学校上课的时间和妈妈安排她上课的时间。
输出格式:
输出包括一行,这一行只包含一个数字。如果不会不高兴则输出0,如果会则输出最不高兴的是周几(用1, 2, 3, 4, 5, 6, 7分别表示周一,周二,周三,周四,周五,周六,周日)。如果有两天或两天以上不高兴的程度相当,则输出时间最靠前的一天。
输入输出样例
输入样例#1:
5 3
6 2
7 2
5 3
5 4
0 4
0 6
输出样例#1:
3
说明
noip2004普及组第1题
作者:
admin
时间:
2018-4-20 19:37
孙老师示范代码:
#include<iostream>
using namespace std;
int a,b,c,i,_max,mi;
int main()
{
_max=mi=0; ///主要变量初始值验证
for (i=1;i<=7;i++) ///一周七天的判断
{
cin>>a>>b;
c=a+b; ///求和
if (c>8){ ///大于8的判断
if (c>_max) {_max=c;mi=i;} ///最大值记录
}
}
if (_max==0) cout<<0;
else cout<<mi;
return 0;
}
复制代码
作者:
xpb
时间:
2018-4-20 19:53
#include<iostream>
#include<cmath>
using namespace std;
int a,b,day,h=0;
int main()
{
for(int i=1;i<=7;i++)
{
cin>>a>>b;
if(h<(a+b) && (a+b)>8)
{
h=a+b;
day=i;
}
else continue;
}
cout<<day;
return 0;
}
作者:
GTR
时间:
2018-4-20 20:01
不高兴的津津:
#include<iostream>
#include<cstdio>
using namespace std;
int main ()
{
int a,b,s,m=0,i,d=0;
for (i=1;i<7;i++)
{
cin>>a>>b;
s=a+b;
if ((s>m)&&(s>8)) m=s,d=i;
}
cout<<d;
return 0;
}
复制代码
作者:
黄昌泰
时间:
2018-4-20 20:13
提示:
作者被禁止或删除 内容自动屏蔽
作者:
尹泽源
时间:
2018-4-20 20:17
提示:
作者被禁止或删除 内容自动屏蔽
作者:
胡炜尧
时间:
2018-5-15 21:42
提示:
作者被禁止或删除 内容自动屏蔽
作者:
胡炜尧
时间:
2018-5-18 18:57
提示:
作者被禁止或删除 内容自动屏蔽
作者:
WJL
时间:
2018-5-18 22:29
#include<iostream>
using namespace std;
int a,b,c,i,_max,mi;
int main()
{
_max=mi=0;
for (i=1;i<=7;i++)
{
cin>>a>>b;
c=a+b;
if (c>8){
if (c>_max) {_max=c;mi=i;}
}
}
if (_max==0) cout<<0;
else cout<<mi;
return 0;
}
复制代码
作者:
WJL
时间:
2018-5-25 19:58
WJL 发表于 2018-5-18 22:29
作者:
WJL
时间:
2018-5-25 23:03
WJL 发表于 2018-5-25 19:58
#include<iostream>
using namespace std;
int a,b,c,i,_max,mi;
int main()
{
_max=mi=0;
for (i=1;i<=7;i++)
{
cin>>a>>b;
c=a+b;
if (c>8){
if (c>_max) {_max=c;mi=i;}
}
}
if (_max==0) cout<<0;
else cout<<mi;
return 0;
}
作者:
倚窗倾听风吹雨
时间:
2018-6-27 08:38
#include<iostream>
using namespace std;
int s[7],e[7],maxt=0,t,c=7;
int main()
{
for(int i=1;i<=7;i++)
cin>>s[i]>>e[i];
for(int i=1;i<=7;i++)
{
if(s[i]+e[i]<=8)c--;
if(s[i]+e[i]>maxt)
{
maxt=s[i]+e[i];
t=i;
}
}
if(c==0)cout<<c;
else cout<<t;
return 0;
}
复制代码
作者:
酱油咸
时间:
2018-6-30 17:27
#include<iostream>
using namespace std;
int a,b,c,i,k;
int main ()
{
for (i=1; i<=7; i++)
{
cin>>a>>b;
if (a+b>c)
{
c=a+b;
k=i;
}
}
if (c>8)
cout<<k;
else cout<<"0";
return 0;
}
江有焓的程序
复制代码
作者:
admin
时间:
2018-6-30 21:00
酱油咸是江有焓的马甲吗?
作者:
universehyf
时间:
2018-7-1 00:00
#include<iostream>
using namespace std;
struct universe{
int z;
int x;
}maxx;
int main()
{
int a,b,pd=0;
maxx.z=0;
for(int i=1;i<=7;i++)
{
cin>>a>>b;
a+=b;
if(a>8)
{
pd=1;
if(a>maxx.z)
{
maxx.z=a;
maxx.x=i;
}
}
}
if(!pd) cout<<pd;
else cout<<maxx.x;
return 0;
}
作者:
酱油咸
时间:
2018-7-2 22:28
#include<iostream>
using namespace std;
int a,b,c,i,k;
int main ()
{
for (i=1; i<=7; i++)
{
cin>>a>>b;
if (a+b>c)
{
c=a+b;
k=i;
}
}
if (c>8)
cout<<k;
else cout<<"0";
return 0;
}
:):):)
复制代码
欢迎光临 华师一附中OI组 (http://hsyit.cn/)
Powered by Discuz! X3.2